username
password
daftar | lupa password  
Keranjang Belanja | Detail
barang, Rp ,-
Di luar PPN, diskon %
 
Cari produk:
 
Halaman Muka
Produk
Voucher MUM
Lisensi (dgn DOM)
Lisensi (tanpa DOM)
Upgrade Lisensi
Cloud Router Switch
Interface
Switch
MikroBits Switch
RouterBoard (only)
Router Indoor
Wireless Indoor NEW
Router Outdoor
RouterBoard 2011
RouterBoard 3011
MikroBits Aneto
MikroBits Ainos
MikroBits Celoica
MikroBits Dinara NEW
Cloud Core Router
Wireless Indoor 800
Wireless Outdoor 800
Wireless Indoor 493
Wireless Indoor 433
Wireless Outdoor 433
Wireless Outdoor 435
Wireless Indoor 411
Wireless Outdoor 411
Wireless Outdoor 900
Wireless Outdoor 711
Groove
Metal
Embedded 2.4GHz
Embedded 5.xGHz
Indoor Antenna
RF Ellements
Outdoor Antenna
SFP Transceiver
Mikrobits Fiber Patch
NetProtector NEW
Perlengkapan Lain
Discontinued
Rancang Sendiri
Aplikasi Bantu
Pelatihan
Manual & Dokumentasi
Download Area
Artikel
Tips & Trik
Mikrotik @ Media
Fitur & Penggunaan
Tentang Kami
Aturan & Tata Cara
Layanan Pelanggan
BGP-Peer NEW
Kontak Kami
 
 
 

Artikel

Forwarding DNS Server

Kategori: Tips & Trik
Share


Seperti yang telah kita ketahui, apabila kita mempunyai sebuah usaha yaitu penyedia jasa internet, seperti RT/RW Net, Internet Cafe (Warnet), atau bisa juga sebagai administrator jaringan di sebuah perusahaan. Maka sesuai dengan peraturan pemerintah atau juga kebijakan dari masing-masing pengelola untuk melakukan filtering akses dari situs-situs yang mengandung unsur SARA, Pornografi, dan situs yang memiliki konten 'negatif'.

Nah, untuk membuat sebuah 'Internet Positif' kita akan melakukan konfigurasi pada router gateway dengan menambahkan DNS Server yang memiliki Content Filtering, seperti DNS Nawala, Comodo Secure DNS, Norton ConnectSafe DNS. Namun seiring dengan perkembangan informasi teknologi, para pengguna internet pun juga tidak ketinggalan untuk update. Sebagian pengguna internet mencari cara untuk menembus dari 'Internet Positif'. Salah satunya dengan mengganti alamat DNS yang telah tersetting di perangkat si pengguna menggunakan alamat DNS tanpa Content Filtering.

Untuk mengatasi hal ini kita bisa menerapkan Forwarding DNS Server atau dengan kata lain kita 'memaksa' pengguna internet untuk melakukan resolve DNS ke DNS Server kita walaupun di perangkat si pengguna disetting dengan DNS Server yang lain. Sebelumnya kita harus melakukan konfigurasi pada DNS Sever di Mikrotik dan pastikan opsi Allow Remote Request dicentang. Hal ini dilakukan supaya IP Address yang ada pada interface Router selain untuk gateway juga bisa dijadikan sebagai alamat DNS Server bagi client.

Dalam membuat Forwarding DNS Server caranya pun cukup mudah. Kita bisa memanfaatkan fitur Firewall-NAT pada MikroTik.



Untuk script rulenya adalah sebagai berikut:

Pada /ip firewall nat

add chain=dstnat action=dst-nat to-addresses=192.168.1.1 to-ports=53 protocol=tcp dst-port=53

add chain=dstnat action=dst-nat to-addresses=192.168.1.1 to-ports=53 protocol=udp dst-port=53

Jadi rule ini akan meredirect semua trafik yang resolve DNS (port 53) menuju ke DNS Server lokal kita. Pastikan untuk menempatkan rule tersebut diurutan paling atas.

DNS Static

Kita juga bisa melakukan kombinasi antara rule firewall NAT dengan fitur 'DNS Static' untuk membuat filtering akses suatu alamat website. Fitur tersebut juga terdapat pada Menu /ip DNS. Untuk konfigurasinya pun juga cukup mudah. Pilih pada tombol command 'Static' kemudian 'Add (+)' dan tentukan DNS Static Entry. Misal, kali ini kita akan filtering akses dari situs www.youtube.com.



Kita juga bisa menentukan dimana situs tersebut akan di-redirect pada parameter 'Address', apakah ke halaman website yang lain atau ke mesin web server local. Dan bisa juga di-redirect ke localhost dari client yang mengakses halaman web itu sendiri.
Nah, sebagai contoh disini kita akan me-redirect ke localhost (127.0.0.1). Karena disini kita menggunakan perangkat client yang juga terinstall webserver maka kita bisa melakukan modifikasi pada tampilan halaman webserver. Apabila kita mengakses halaman www.youtube.com maka akan tampil seperti berikut.






Kembali ke :
Halaman Artikel | Kategori Tips & Trik

 

muka - tentang kami - produk - artikel - kontak kami
 
Copyrights 2005-2017 Citraweb Nusa Infomedia. All Rights Reserved. Generated in 0.0103 second(s).
Your IP: 54.204.106.194