username
password
daftar | lupa password  
Keranjang Belanja | Detail
barang, Rp ,-
Di luar PPN, diskon %
 
Cari produk:
 
Halaman Muka
Produk
Voucher MUM
Lisensi (dgn DOM)
Lisensi (tanpa DOM)
Upgrade Lisensi
Cloud Router Switch
Interface
Switch
MikroBits Switch
RouterBoard (only)
Router Indoor
Wireless Indoor NEW
Router Outdoor
RouterBoard 2011
RouterBoard 3011
MikroBits Aneto
MikroBits Ainos
MikroBits Celoica
MikroBits Dinara NEW
Cloud Core Router
Wireless Indoor 800
Wireless Outdoor 800
Wireless Indoor 493
Wireless Indoor 433
Wireless Outdoor 433
Wireless Outdoor 435
Wireless Indoor 411
Wireless Outdoor 411
Wireless Outdoor 900
Wireless Outdoor 711
Groove
Metal
Embedded 2.4GHz
Embedded 5.xGHz
Indoor Antenna
RF Ellements
Outdoor Antenna
SFP Transceiver
Mikrobits Fiber Patch
NetProtector NEW
Perlengkapan Lain
Discontinued
Rancang Sendiri
Aplikasi Bantu
Pelatihan
Manual & Dokumentasi
Download Area
Artikel
Tips & Trik
Mikrotik @ Media
Fitur & Penggunaan
Tentang Kami
Aturan & Tata Cara
Layanan Pelanggan
BGP-Peer NEW
Kontak Kami
 
 
 

Artikel

Load Balance metode NTH

Kategori: Fitur & Penggunaan
Share


Seiring dengan perkembangan teknologi khususnya dalam bidang internet, banyak sekali bermunculan Internet Provider (ISP). Dan tidak bisa dipungkiri untuk saat ini kebutuhan akan internet merupakan sebuah kebutuhan yang pokok. Mulai dari akses informasi sampai jual-beli online sudah menjadi hal biasa.

Karena didorong oleh banyaknya permintaan dari masyarakat akan koneksi internet, maka banyak perusahaan internet provider berlomba-lomba memberikan layanan dan juga produk yang terbaik. Dan tak khayal saat ini banyak tawaran untuk koneksi internet dengan harga yang semakin terjangkau.

Dan bahkan mungkin diantara kita juga ada yang berlangganan service internet lebih dari satu provider. Nah, dengan multiple gateway ini cukup penting dalam sisi management sehingga koneksi internet yang kita miliki bisa berjalan secara optimal untuk masing-masing link. Salah satu metode yang paling banyak digunakan adalah dengan cara load balace. Dari load balance sendiri ada beberpa mekanisme yang bisa digunakan antara lain ECMP (Equal-Cost Multiple Path), NTH, PCC (Per-Connection Classifier).

Pada artikel sebelumnya telah kita bahas metode ECMP & PCC, dan supaya lebih lengkap kali ini kita akan membahas mengenai load balance dengan NTH.

Apa itu NTH?

NTH sendiri adalah sebuah fitur pada firewall yang digunakan sebagai penghitung (counter) dari paket data atau koneksi (packet new). Ada dua parameter utama dari NTH ini, yaitu "Every" dan "Packet".

"Every" merupakan parameter penghitung (counter) sedangkan "Packet" adalah penunjuk paket keberapa rule dari NTH ini akan dijalankan. Dengan demikian penggunaan NTH ini dilakukan denganmengaktifkan counter pada mangle, kemudian ditandai dengan 'Route-Mark'. Sehingga dengan route mark ini digunakan sebagai dasar untuk membuat policy route.

Konfigurasi NTH

Kita akan mencoba melakukan konfigurasi load balance menggunakan metode NTH. Seperti pada topologi dibawah ini, kita memiliki dua gateway untuk koneksi ke internet.

 

Berdasarkan mekanisme NTH, untuk topologi diatas setiap trafik/paket data yang lewat akan dibagi menjadi 1 dan 2. Kemudian untuk link ISP-A akan digunakan untuk jalur paket 1 dan link ISP-B akan digunakan untuk jalur paket 2.

Langkah, pertama kita akan buat rule mangle terlebih dahulu untuk membuat routing-mark berdasarkan parameter NTH. Masuk ke menu IP --> Firewall --> Mangle. Tambahkan rule seperti berikut.

/ip firewall mangle
add action=mark-connection chain=prerouting in-interface=ether5 new-connection-mark=conn-1 nth=2,1
add action=mark-connection chain=prerouting in-interface=ether5 new-connection-mark=conn-2 nth=2,2
add action=mark-routing chain=prerouting connection-mark=conn-1 new-routing-mark=jalur-1 passthrough=no
add action=mark-routing chain=prerouting connection-mark=conn-2 new-routing-mark=jalur-2 passthrough=no

Setelah membuat mangle, kita akan mengatur policy routing untuk menentukan jalur trafik ke masing-masing gateway.

/ip route
add distance=1 gateway=172.16.1.1 routing-mark=jalur-1
add distance=1 gateway=192.168.1.1 routing-mark=jalur-2
add distance=1 gateway=172.16.1.1,192.168.1.1

Pada routing diatas terdapat 3 default gateway. Untuk gateway baris 1 dan 2 merupakan gateway untuk trafik dari LAN di ether5, sedangkan baris ke 3 merupakan gateway untuk trafik selain dari LAN (misal, trafik local process).





Kembali ke :
Halaman Artikel | Kategori Fitur & Penggunaan

 

muka - tentang kami - produk - artikel - kontak kami
 
Copyrights 2005-2017 Citraweb Nusa Infomedia. All Rights Reserved. Generated in 0.0103 second(s).
Your IP: 54.158.99.141